aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2012-01-19 17:22:48 -0800
committerThomas White <taw@physics.org>2012-02-22 15:27:43 +0100
commit4355449194274d766fb0aec964e6bfce8fa9acdf (patch)
tree2bd5f62ce7fe1ac7c1074131df401fab147204c2 /configure.ac
parent6c5ecd972440e2a3ba9947c8f480dd03af039089 (diff)
Use Pango cflags and libraries separately
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 05d4f15d..9590ae62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -276,7 +276,7 @@ gl_IGNORE_UNUSED_LIBRARIES
MAIN_CFLAGS="$CFLAGS $HDF5_CFLAGS $GSL_CFLAGS $OPENCL_CFLAGS -pthread"
MAIN_CFLAGS="$MAIN_CFLAGS $GTK_CFLAGS $LIBTIFF_CFLAGS -D_GNU_SOURCE "
MAIN_CFLAGS="$MAIN_CFLAGS $libPNG_CFLAGS $Cairo_CFLAGS $GDK_pixbuf_CFLAGS"
-MAIN_CFLAGS="$MAIN_CFLAGS $GDK_pixbuf_2_CFLAGS $FFTW_CFLAGS"
+MAIN_CFLAGS="$MAIN_CFLAGS $GDK_pixbuf_2_CFLAGS $FFTW_CFLAGS $Pango_CFLAGS"
AC_SUBST([MAIN_CFLAGS])
LIBCRYSTFEL_CFLAGS="$CFLAGS $HDF5_CFLAGS $GSL_CFLAGS $FFTW_CFLAGS"
@@ -284,7 +284,8 @@ AC_SUBST([LIBCRYSTFEL_CFLAGS])
MAIN_LIBS="$LIBS $HDF5_LIBS -lm -lz $GSL_LIBS $GTK_LIBS $OPENCL_LIBS -pthread"
MAIN_LIBS="$MAIN_LIBS $LIBTIFF_LIBS $libPNG_LIBS $Cairo_LIBS $GDK_pixbuf_LIBS"
-MAIN_LIBS="$MAIN_LIBS $GDK_pixbuf_2_LIBS $TIMER_LIBS $FFTW_LIBS $LDFLAGS"
+MAIN_LIBS="$MAIN_LIBS $GDK_pixbuf_2_LIBS $TIMER_LIBS $FFTW_LIBS"
+MAIN_LIBS="$MAIN_LIBS $Pango_LIBS $LDFLAGS"
AC_SUBST([MAIN_LIBS])
LIBCRYSTFEL_LIBS="$LIBS $HDF5_LIBS $GSL_LIBS $FFTW_LIBS $LDFLAGS"