summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2010-02-05 13:55:32 -0500
committerKristian Høgsberg <krh@bitplanet.net>2010-02-05 13:55:45 -0500
commit077bc2fda2afdbe0bf12e1baeafa4ce41b711d1d (patch)
treef51160a826ffc112851718f68d0b438155b877e5 /configure.ac
parente423df0f0c3e5a5d33d301b6176e9380e61b98ad (diff)
egl_dri2: Use pkg-config cflags and libs from configure output
Running pkg-config in Makefiles is bad form, since it doesn't respect the PKG_CONFIG_PATH value set at ./configure time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index af5a5fdc4b..b6c6535fc6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -918,8 +918,8 @@ if test "x$enable_egl" = xyes; then
fi
# build egl_dri2 when xcb-dri2 is available
- PKG_CHECK_EXISTS([x11-xcb xcb-dri2 xcb-xfixes],
- [have_xcb_dri2=yes],[have_xcb_dri2=no])
+ PKG_CHECK_MODULES([EGL_DRI2], [x11-xcb xcb-dri2 xcb-xfixes libdrm],
+ [have_xcb_dri2=yes],[have_xcb_dri2=no])
if test "$have_xcb_dri2" = yes; then
EGL_DRIVERS_DIRS="$EGL_DRIVERS_DIRS dri2"
fi