summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2010-02-03 10:18:28 -0500
committerKristian Høgsberg <krh@bitplanet.net>2010-02-04 15:03:45 -0500
commit42fa009e641c35a6543f2fb63b229c0adc8a30dc (patch)
tree196a2e0364c72117e2e0a4f88e6665c0170dbe0a /configure.ac
parent7b6fa78d86612b73e662dc6981d32ef3cd534642 (diff)
egl: Add driver for EGL on X with DRI2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 10e0bd47ab..16d315e13a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -915,6 +915,10 @@ if test "x$enable_egl" = xyes; then
# build egl_glx when libGL is built
EGL_DRIVERS_DIRS="glx"
fi
+ if test "$mesa_driver" == dri; then
+ # build egl_dri2 when dri is enabled
+ EGL_DRIVERS_DIRS="$EGL_DRIVERS_DIRS dri2"
+ fi
fi
AC_SUBST([EGL_LIB_DEPS])
AC_SUBST([EGL_DRIVERS_DIRS])
@@ -1395,7 +1399,11 @@ dnl Libraries
echo ""
echo " Shared libs: $enable_shared"
echo " Static libs: $enable_static"
-echo " EGL: $enable_egl"
+if test "$enable_egl" = yes; then
+ echo " EGL: $EGL_DRIVERS_DIRS"
+else
+ echo " EGL: no"
+fi
echo " GLU: $enable_glu"
echo " GLw: $enable_glw (Motif: $enable_motif)"
echo " glut: $enable_glut"