summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olvaffe@gmail.com>2010-01-22 15:18:45 +0800
committerChia-I Wu <olvaffe@gmail.com>2010-01-22 15:37:56 +0800
commit52d7b2cedee44fbd9a0e6405b974c62898bed169 (patch)
tree37eeff928e3ca970d0a25b0e02477cdb3f8970cc /configure.ac
parent2a928899e345e400c4266910b4e33b36a20575e2 (diff)
st/egl: Remove the egl state tracker.
The egl_g3d state tracker has support for KMS, and the support is based on the egl state tracker. As egl_g3d provides more features, it should be better to keep only egl_g3d to unify the efforts.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e5c2386320..bb011abff2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1165,7 +1165,7 @@ yes)
dri)
GALLIUM_STATE_TRACKERS_DIRS="dri"
if test "x$enable_egl" = xyes; then
- GALLIUM_STATE_TRACKERS_DIRS="$GALLIUM_STATE_TRACKERS_DIRS egl egl_g3d"
+ GALLIUM_STATE_TRACKERS_DIRS="$GALLIUM_STATE_TRACKERS_DIRS egl_g3d"
fi
# Have only tested st/xorg on 1.6.0 servers
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.6.0],
@@ -1182,9 +1182,9 @@ yes)
AC_MSG_ERROR([state tracker '$tracker' doesn't exist])
case "$tracker" in
- egl)
+ egl_g3d)
if test "x$enable_egl" != xyes; then
- AC_MSG_ERROR([cannot build egl state tracker without EGL library])
+ AC_MSG_ERROR([cannot build egl_g3d state tracker without EGL library])
fi
;;
xorg)