summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakob Bornecrantz <jakob@vmware.com>2010-01-14 22:51:25 +0000
committerJakob Bornecrantz <jakob@vmware.com>2010-01-14 22:51:25 +0000
commit877cadb65512a93f3ccf2f25bbc2f7565d75050f (patch)
treebc1aa22ee2102a15e56d3dfa981ad403b07a5c9f /configure.ac
parentb01ffb12ed82dcf435b186e2aff35e344a8a6ebe (diff)
r300g: Build driver by default
Do the auto trick that is used for both i915, i965 and svga.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4f28fc0d14..d01d0f1884 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1279,10 +1279,12 @@ AC_ARG_ENABLE([gallium-radeon],
[AS_HELP_STRING([--enable-gallium-radeon],
[build gallium radeon @<:@default=disabled@:>@])],
[enable_gallium_radeon="$enableval"],
- [enable_gallium_radeon=no])
+ [enable_gallium_radeon=auto])
if test "x$enable_gallium_radeon" = xyes; then
GALLIUM_WINSYS_DRM_DIRS="$GALLIUM_WINSYS_DRM_DIRS radeon"
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r300"
+elif test "x$enable_gallium_radeon" = xauto; then
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r300"
fi
dnl