summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olvaffe@gmail.com>2010-01-05 17:39:05 +0800
committerChia-I Wu <olvaffe@gmail.com>2010-01-12 11:25:09 +0800
commit99a37ed195801fd0a0b64a20f08c8d4f9d66137f (patch)
tree3b95e3a9c0e5031505110e64b24e40ee43dde3a3 /configure.ac
parent3f3340ca16a07aff26a3bd27a7f5ae161d77b11d (diff)
configure.ac: Fix es state tracker build.
mesa/es should be built before the es state trackers. This is done by separating those that need to be built early from SRC_DIRS to CORE_DIRS. The new variable is not exported, and will be prepended to SRC_DIRS. Signed-off-by: Chia-I Wu <olvaffe@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1f94248824..a5e181dbf4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -419,7 +419,11 @@ esac
dnl
dnl Driver specific build directories
dnl
-SRC_DIRS="glsl mesa glew"
+
+dnl this variable will be prepended to SRC_DIRS and is not exported
+CORE_DIRS="glsl mesa"
+
+SRC_DIRS="glew"
GLU_DIRS="sgi"
WINDOW_SYSTEM=""
GALLIUM_DIRS="auxiliary drivers state_trackers"
@@ -434,7 +438,7 @@ xlib)
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS xlib"
;;
dri)
- SRC_DIRS="glx/x11 $SRC_DIRS"
+ CORE_DIRS="glx/x11 $CORE_DIRS"
DRIVER_DIRS="dri"
WINDOW_SYSTEM="dri"
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS drm"
@@ -1191,7 +1195,7 @@ yes)
;;
es)
# mesa/es is required to build es state tracker
- SRC_DIRS="mesa/es $SRC_DIRS"
+ CORE_DIRS="$CORE_DIRS mesa/es"
;;
esac
done
@@ -1306,6 +1310,8 @@ if test "x$enable_gallium_nouveau" = xyes; then
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS nouveau nv04 nv10 nv20 nv30 nv40 nv50"
fi
+dnl prepend CORE_DIRS to SRC_DIRS
+SRC_DIRS="$CORE_DIRS $SRC_DIRS"
dnl Restore LDFLAGS and CPPFLAGS
LDFLAGS="$_SAVE_LDFLAGS"