summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2010-01-02 18:59:54 -0500
committerKristian Høgsberg <krh@bitplanet.net>2010-01-03 15:40:59 -0500
commite388d62b4712bcd75cecad53f5ca20a2bb6f89b1 (patch)
treea9b6668f2a280d8828f45365c484b5769b1af5de /configure.ac
parenta60084088baca0981e5b0f1512831683cd4f25bc (diff)
Compile with -fvisibility-hidden by default
We have all functions that need to be visible marked with PUBLIC and this is trimming around 4% off the DRI driver .so size.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 72afabcf9e..b2a969bc8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,7 +95,7 @@ esac
dnl Add flags for gcc and g++
if test "x$GCC" = xyes; then
- CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -std=c99 -ffast-math"
+ CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -std=c99 -ffast-math -fvisibility=hidden"
# Work around aliasing bugs - developers should comment this out
CFLAGS="$CFLAGS -fno-strict-aliasing"