summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJesse Barnes <jbarnes@virtuousgeek.org>2010-01-11 17:28:10 -0500
committerJesse Barnes <jbarnes@virtuousgeek.org>2010-01-11 17:30:41 -0500
commitf2f83d9a7891428ea7c784a75bd9e2968fdf00ae (patch)
treed98716afe064fbd3e36d34503f85a1bbef3efb02 /configure.ac
parentc6ef705e414c8e93ee471f50d15ada3492a9b067 (diff)
GLX: check glproto version
This was a silent dependency before, but now we really need 1.4.11 for INTEL_swap_event support, so check for it. Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 33437f54f8..b388723113 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,7 @@ dnl Versions for external dependencies
LIBDRM_REQUIRED=2.4.15
LIBDRM_RADEON_REQUIRED=2.4.17
DRI2PROTO_REQUIRED=2.2
+GLPROTO_REQUIRED=1.4.11
dnl Check for progs
AC_PROG_CPP
@@ -577,6 +578,7 @@ dri)
PKG_CHECK_MODULES([DRI2PROTO], [dri2proto >= $DRI2PROTO_REQUIRED])
GL_PC_REQ_PRIV="libdrm >= $LIBDRM_REQUIRED dri2proto >= $DRI2PROTO_REQUIRED"
DRI_PC_REQ_PRIV="libdrm >= $LIBDRM_REQUIRED"
+ PKG_CHECK_MODULES([GLPROTO], [glproto >= $GLPROTO_REQUIRED])
# find the DRI deps for libGL
if test "$x11_pkgconfig" = yes; then